вторник, 10 апреля 2012 г.

Друкована форма на СКД



Создание печатной формы ТЧ документа с использованием СКД
Создаем макет СКД, там произвольно или с какими-нибудь условиями выбираем в наборе данных поля табличной части, ставим условие на документ владелец,  и задаем оформление. В форме документа добавляем кнопку печать, прописываем в параметрах наш документ и оп-ля - печатная форма готова

Процедура ОсновныеДействияФормыПечать(Кнопка)



 Если 
Ссылка Документы.РасчетЗаказа.ПустаяСсылка() тогда

 
Предупреждение("Документ не записан");

 Возврат;

 Иначе

 
Схема ПолучитьМакет("Макет1");

 
Настройки Схема.НастройкиПоУмолчанию;

 
КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();

 
КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);



 
ПараметрДок = Новый ПараметрКомпоновкиДанных("документ");

 
ЗначениеПараметраДок КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрДок);

 
ЗначениеПараметраДок.Значение Ссылка;

 
ЗначениеПараметраДок.Использование = Истина;

 
Настройки КомпоновщикНастроек.Настройки;



 
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;

 
МакетКомпоновки КомпоновщикМакета.Выполнить(СхемаНастройки);

 
ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;

 
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки);

 
ДокументРезультат = Новый ТабличныйДокумент;

 
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;

 
ПроцессорВывода.УстановитьДокумент(ДокументРезультат);

 
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);



 
ДокументРезультат.ОтображатьЗаголовки = Ложь;

 
ДокументРезультат.ОтображатьСетку = Ложь;

 
ДокументРезультат.АвтоМасштаб = Истина;

 
ДокументРезультат.Показать();



 КонецЕсли;



КонецПроцедуры


воскресенье, 5 февраля 2012 г.

Запрос к Таблице Значений

Запрос к Таблице Значений

Код 1C v 8.х
 Таблица = Новый ТаблицаЗначений;
//Опишем тип создаваемой колонки
Массив = Новый Массив;
КЧ = Новый КвалификаторыЧисла(10, 2);
Массив.Добавить(Тип("Число"));
ОписаниеТиповЧ = Новый ОписаниеТипов(Массив, , ,КЧ);
Таблица.Колонки.Добавить("КодУслуги",ОписаниеТиповЧ);

//... выборки из справочника и заполнение ТЗ
Пока ВыборкаСпр.Следующий() Цикл
       НоваяСтрока = Таблица.Добавить();   
       НоваяСтрока.КодУслуги = ВыборкаСпр.Код;   
КонецЦикла;
  
Запрос = Новый Запрос;
МенеджерВТ = Новый МенеджерВременныхТаблиц;
Запрос.МенеджерВременныхТаблиц = МенеджерВТ;
// Текст запроса для построения временной таблицы
Запрос.Текст = "ВЫБРАТЬ
                  |    Таб.КодУслуги КАК Код
                  |ПОМЕСТИТЬ ВТДанные
                  |ИЗ
                  |    &Данные КАК Таб";
Запрос.УстановитьПараметр("Данные",Таблица);
Результат = Запрос.Выполнить();   


Пример Заполнения колонки одной таблицы по колонке другой, по типу ЛЕВОЕ СОЕДИНЕНИЕ
Это удобно когда например надо заполнить колонку не одним фиксированным значением, а в зависимости от значений в других колонках
Код 1C v 8.х
 
   ТЗН1 = Новый ТаблицаЗначений;//Колонки Кол1,кол2,кол3,ИД
   ТЗН2 = Новый ТаблицаЗначений;//Колонки Кол4,кол5,кол6,ИД
 
    Запрос.УстановитьПараметр("ТЗН1",Отправления);
    Запрос.УстановитьПараметр("ТЗН2",ЛотыКСписанию);
    МВТ = Новый МенеджерВременныхТаблиц;
    Запрос.МенеджерВременныхТаблиц = МВТ;
    //Запрос 1 Помещаем ТЗН1 в МенеджерВременныхТаблиц в таблицу ТЗН1
 
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ТЗН1.Кол1 КАК Кол1,
    |    ТЗН1.Кол2 КАК Кол2,
    |    ТЗН1.Кол3 КАК Кол3,
    |    ТЗН1.ИД   КАК ИД
    |ПОМЕСТИТЬ
    |    ТЗН1
    |ИЗ
    |    &ТЗН1 КАК ТЗН1";
    Запрос.Выполнить();
    //Запрос 2 Помещаем ТЗН2 в МенеджерВременныхТаблиц в таблицу ТЗН2
 
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ТЗН2.Кол1 КАК Кол4,
    |    ТЗН2.Кол2 КАК Кол5,
    |    ТЗН2.Кол3 КАК Кол6,
    |    ТЗН2.ИД   КАК ИД
    |ПОМЕСТИТЬ
    |    ТЗН2
    |ИЗ
    |    &ТЗН2 КАК ТЗН2";
    //Получаем результирующую таблицу
 
    Запрос.Выполнить();
    Запрос.Текст = 
        "ВЫБРАТЬ
    |    ТЗН1.Кол1 КАК Кол1,
    |    ТЗН1.Кол2 КАК Кол2,
    |    ТЗН1.Кол3 КАК Кол3,
    |    ТЗН1.ИД   КАК ИД,
    |    ТЗН2.Кол1 КАК Кол4,
    |    ТЗН2.Кол2 КАК Кол5,
    |    ТЗН2.Кол3 КАК Кол6,
    |ИЗ
    |    ТЗН1 КАК ТЗН1
    |   ВНУТРЕННЕЕ СОЕДИНЕНИЕ ТЗН2 КАК ТЗН2
    |   ПО ТЗН1.ИД = ТЗН2.ИД";
    тзн3 = Запрос.Выполнить().Выгрузить(); 
 
Взято с http://help1c.com/faq/view/815.html